Access Denied Users.usr On New Machine
Solution Available
Kenny K.
Milwaukee, WI

Aug 15, 2016
10 Posts

Access Denied Users.usr on new machine

I am getting an access denied error when I try to close the ATEasy test program on a new installation.

Our test rack was running windows XP with AT Easy 8 (146a).  The PC had a hardware problem and had to be replaced.  The new PC no longer had Windows XP drivers, so we had to go to Windows 7.

I installed ATEasy 8 (148d) as a runtime, and LabVIEW 2009 SP1 runtime as well as the VISA drivers.

The ATEasy test program will open up on the main screen, but even if I do not do anything and just click Exit, I get an error that the users.usr access has been denied.

We have verified that the user account under Windows 7 has permissions to the folder, and the user account is also an administrator.

Any ideas on what is causing the file access errors?

DrATEasy (Ron Y.)
Mission Viejo,

Aug 16, 2016
244 Posts

Re: Access Denied Users.usr on new machine

Do you mean ATEasy.usr?

So the issue is when you run the application but not when you run ATEasy IDE?

What's the path you set in you application TestExec to the usr file or you are just using the default path?  (C:\Windows\SysWOW64 or C:\Windows\System32).

Kenny K.
Milwaukee, WI

Aug 16, 2016
10 Posts

Re: Access Denied Users.usr on new machine

Sorry, I didnt specify correctly.

The Users.usr was a custom name for the ATEasy.usr that was set in the build specification.

I am running a built application (exe).

The file is relative to the exe location.

In the IDE, I set the name value to user.usr.

Edit:  Problem solved.  The files were copied over as read only for some reason.  So even though the Windows Account had full permissions, the file was still marked read-only.

Shaik A.
hyderabad,

May 4, 2017
1 Post

Re: Access Denied Users.usr on new machine

Kenny K. wrote:
I am getting an access denied error when I try to close the ATEasy test program on a new installation.

Our test rack was running windows XP with AT Easy 8 (146a).  The PC had a hardware problem and had to be replaced.  The new PC no longer had Windows XP drivers, so we had to go to Windows 7.

I installed ATEasy 8 (148d) as a runtime, and LabVIEW 2009 SP1 runtime as well as the VISA drivers.

The ATEasy test program will open up on the main screen, but even if I do not do anything and just click Exit, I get an error that the users.usr access has been denied.

We have verified that the user account under Windows 7 has permissions to the folder, and the user account is also an administrator.

Any ideas on what is causing the file access errors?



Please Note
You need to have a M@GIC account to participate in the Forums.
Not yet registered on our website? Click here to register today!

All content, information and opinions presented on the Marvin Test Solutions User Forums are those of the authors of the posts and messages and not Marvin Test Solutions'. All attachments and files are downloaded at your own risk. [Read More]