NationalInstruments.Common Assembly Error
Paul T.
Maennedorf, Zurich

Feb 3, 2015
54 Posts

NationalInstruments.Common Assembly Error

Hi all,


I have NIDAQmx version 9.7.5 installed, and I am trying to use an ATEasy project that uses NationalInstruments.Common assembly. It constantly retrieves me the error:

Run-time error #420 : 'Object method or property 'Init' failed: Could not load file or assembly 'NationalInstruments.Common, Version=8.5.35.149, Culture=neutral, PublicKeyToken=18cbae0f9955702a' or one of its dependencies. The system cannot find the file specified.' found in 'Ni_Generic.InitAnalog' in line 26.



What to do?


Please help me!


Regards,
Alex

Victor B.
Lake Forest, CA

Feb 5, 2015
93 Posts

Re: NationalInstruments.Common Assembly Error

Hi Alex,

For operating an instrument that utilizes NI-DAQmx, we have a premade driver that is packaged with ATEasy.  Is this suitable?

Check "C:\Program Files (x86)\ATEasy\Drivers\NiDaqMx.prj"

Regards,
Victor Brode

Solution Available
Paul T.
Maennedorf, Zurich

Feb 5, 2015
54 Posts

Re: NationalInstruments.Common Assembly Error

Hi Victor,


I have to work within a project that already has those NI .NET assemblies included.
I've managed to install these assemblies at their old versions and now it works.


Thanks anyway!



Regards,
Alex P.



Please Note
You need to have a M@GIC account to participate in the Forums.
Not yet registered on our website? Click here to register today!

All content, information and opinions presented on the Marvin Test Solutions User Forums are those of the authors of the posts and messages and not Marvin Test Solutions'. All attachments and files are downloaded at your own risk. [Read More]