ATEasy iviScope Driver

Michael W.
Lititz, PA

Jan 2, 2013
30 Posts

0  |  0  

Re: ATEasy iviScope Driver

I'm attempting to use the ATEasy iviScope driver to control a Tektronix DPO4000 oscilloscope (DPO4104 to be specific.)  The ATEasy driver shortcut properties, as shown on the attached file, is correct.  The Vendor ID and Product ID match the value shown in Tektronix's programming manual.  The serial number matches the number on the bottom of the scope.  Even still, I keep getting a run-time error every time I try to execute a command, such as Reset, Initiate or AutoSetup.  I've tried checking and unchecking the 'Open on Access' box, but I get the same error no matter.  I don't understand what I'm doing wrong.  Can anybody offer a solution to my problem?  Thanks.

File Attachment:
Runtime Error.png

Solution Available
Victor B.
Lake Forest, CA

Jan 2, 2013
93 Posts

1  |  0  

Re: ATEasy iviScope Driver

Change the interface back to 'None'.  Then assign an alias/logical name in MAX for your DPO4104.  For example, name the device 'MyDevice'.  Finally, go back to ATEasy and click on the Misc tab in your IviScope Driver Shortcut Properties.  Set the LogicalName parameter to 'MyDevice' or whatever alias you used.

I have posted a pic of the final setting of the Driver Shortcut properties.

-Victor Brode

File Attachment:

Please Note
You need to have a M@GIC account to participate in the Forums.
Not yet registered on our website? Click here to register today!

All content, information and opinions presented on the Marvin Test Solutions User Forums are those of the authors of the posts and messages and not Marvin Test Solutions'. All attachments and files are downloaded at your own risk. [Read More]