David N.
Salt Lake CIty, UT

Nov 5, 2021
7 Posts

0  |  0  

Re: MCC IPort

Hi,

I'm looking to communicate with these I2C Bus adapters. Top hyperlink is the current I2C pod that I'm working with. The bottom is the legacy I2C adapter. It would be very helpful if I can get both of them to work. Can you provide a Ateasy driver for this?

I will attach the legacy I2C .dll's and header files.

https://mcc-us.com/iPortUSB-2/index.html

https://mcc-us.com/iPortUSB/index.html


Thanks,

Boi-Hien H.
IRVINE, CA

Nov 8, 2021
6 Posts

0  |  0  

Re: MCC IPort

Hi David,

We can develop this driver for you. I'll update you once it is finished.

Regards,
Boi-Hien

Solution Available
Boi-Hien H.
IRVINE, CA

Nov 11, 2021
6 Posts

1  |  0  

Re: MCC IPort

Hi David,

Attached below is the driver for the McciPortUsb2. Please note that there was no way for us to test the driver since we do not have the actual instrument.

If you have any questions please refer to the ASCII Command Interface Programmer's Guide from Micro Computer Control Corporation as that is what the driver was based on.

Regards,
Boi-Hien


File Attachment:
McciPortUsb2.zip

David N.
Salt Lake CIty, UT

Nov 11, 2021
7 Posts

0  |  0  

Re: MCC IPort

Thanks Boi-Hein for providing this driver. much appreciated.

I tested the diver with the I2C USB 2 device. I get a runtime error#378.

I've installed all of the necessary drivers and set the com ports accordantly.

See attachment Capture.PNG. Seems to run the flow control statement ok.


Regards, David Nielson


File Attachment:
Capture.PNG

David N.
Salt Lake CIty, UT

Nov 11, 2021
7 Posts

0  |  0  

Re: MCC IPort

Thanks Boi-Hein for providing this driver. much appreciated.

I tested the diver with the I2C USB 2 device. I get a runtime error#378.

I've installed all of the necessary drivers and set the com ports accordantly.

See attachment Capture.PNG. Seems to run the flow control statement ok.


Regards, David Nielson


File Attachment:
Capture.PNG

Boi-Hien H.
IRVINE, CA

Nov 11, 2021
6 Posts

0  |  0  

Re: MCC IPort

Hi David,

Thank you for the screen capture. I was not able to debug the example tests without the instrument. I see that the Set Address Destination command was able to retrieve the "*" meaning that it was able to communicate with the device.

The runtime error might be caused by unnecessary calls to receive a response (the command already calls the retrieve string). Please reference the command interface guide attached below.

Regards,
Boi-Hien


File Attachment:
ASCII_Command_Interface_Programmer's_Guide.pdf

David N.
Salt Lake CIty, UT

Nov 17, 2021
7 Posts

0  |  0  

Re: MCC IPort

Thanks again for what you provided. Much appreciated.

I've made some progress by going with what you suggested. I believe its is now working by including the response string in the IO table.

Then I was having trouble getting the response from the Open command and firmware version command. the only thing that made a significant impact is to change the Input terminations to NONE and Output Terminations to \r. When this is set , I get the excepted response only it has \r\n* or \r\n OCC in the response string.

I've looked over the ASCII command pdf , I  cant seem to figure out what I'm doing wrong. Any suggestions?


File Attachment:
IO monitor.PNG

Boi-Hien H.
IRVINE, CA

Nov 17, 2021
6 Posts

0  |  0  

Re: MCC IPort

Hi David,

I've changed the Output Terminator to NONE for the driver. The extra \r\n at the beginning of the response might be because the device is already sending a [CR] and we are sending another one. I also see that the device did not respond to the Reset command. I've changed the terminator for send IOTables to ",".

Additionally, you may need to change the TestResult in the Examples since I did not know the exact response the device was going to give. We are getting the expected responses, but the input/output terminator just seems to be off.

Please see the attached file and let me know if the changes work.

Regards,
Boi-Hien


File Attachment:
McciPortUsb2.zip



Please Note
You need to have a M@GIC account to participate in the Forums.
Not yet registered on our website? Click here to register today!

All content, information and opinions presented on the Marvin Test Solutions User Forums are those of the authors of the posts and messages and not Marvin Test Solutions'. All attachments and files are downloaded at your own risk. [Read More]